Index of /grass64/binary/linux/snapshot

[ICO]NameLast modifiedSizeDescription

[PARENTDIR]Parent Directory  -  
[TXT]README.html2012-12-27 08:57 4.0K 
[   ]build.log2018-08-25 03:21 4.9M 
[TXT]config_6.4.svn_log.txt2018-08-25 03:21 10K 
[   ]error.log2018-08-25 03:21 190  
[TXT]grass-6.4.6svn-x86_64-pc-linux-gnu-25_08_2018-install.sh2018-08-25 03:21 10K 
[   ]grass-6.4.6svn-x86_64-pc-linux-gnu-25_08_2018.tar.gz2018-08-25 03:21 25M 
[TXT]grass-6.4_x86_64-pc-linux-gnu_bin.txt2018-08-25 03:21 1.4K 
[TXT]grass-6.4_x86_64-unknown-linux-gnu_bin.txt2015-12-26 03:21 1.4K 
[TXT]i18n_stats.txt2018-08-25 03:21 6.5K 
[TXT]i18n_stats_libs.txt2018-08-25 03:21 90  
[TXT]i18n_stats_mods.txt2018-08-25 03:21 0  
[TXT]i18n_stats_nviz.txt2018-08-25 03:21 0  
[TXT]i18n_stats_tcl.txt2018-08-25 03:21 0  
[TXT]i18n_stats_wxpy.txt2018-08-25 03:21 0  

GRASS 6.4.svn stable (release branch) snapshot GNU/Linux binaries

GRASS 6.4.svn stable snapshot GNU/Linux binaries

How to install the Linux (x86/Intel) binary code for GRASS 6.4.svn stable (release branch) in gzipped tar format.

Note: the x86_64 binaries will only run on 64bit CPUs (use 'uname -m' to find out about your computer).

You can install and use GRASS 6 in parallel to GRASS 7.x.

Installation:

  1. get the file
    grass-6.4.svn-ARCH-DD_MM_YYYY.tar.gz
  2. get the installation script
    grass-6.4.svn-ARCH-DD_MM_YYYY-install.sh

where

For installation, run the install script with --help option:


Or without help, directly:

Libraries

The following libraries and programs are required: and, recommended, also:

NOTE:

In some distributions (e.g. Debian, Mandriva) the names of libraries are slightly different. Check, and if there is no file of the name:
libtk.so.0
libtcl.so.0
libpq.so.2
libgdal.so.1
libdfftw.so.2

then you should type:

su
ln -s /usr/lib/libtk.so /usr/lib/libtk.so.0
ln -s /usr/lib/libtcl.so /usr/lib/libtcl.so.0
ln -s /usr/lib/libpq.so.3 /usr/lib/libpq.so.2
ln -s /usr/lib/libgdal.1.1.so /usr/lib/libgdal.so.1
ln -s /usr/lib/libfftw.so.2 /usr/lib/libdfftw.so.2
ldconfig

As a first argument, you should put the names of the libraries you have in your distribution.
Instead of (or in addition to) libtk.so and libtcl.so, you might have libtk8.3.so and libtcl8.3.so (or libtk8.4.so and libtcl8.4.so). In this case, type instead:

ln -s /usr/lib/libtk8.3.so /usr/lib/libtk.so.0
ln -s /usr/lib/libtcl8.3.so /usr/lib/libtcl.so.0
ldconfig

How to uninstall

sh /usr/local/bin/grass64uninstall.sh
If it's not there, then:
rm -rf /usr/local/bin/grass64
rm -rf /usr/local/bin/grass64-DD-MM-YYYY
rm -rf /usr/local/grass64-DD-MM-YYYY


This snapshot was configured as follows:
CFLAGS="-O2" LDFLAGS="-s" ./configure \
  --enable-64bit \
  --with-libs=/usr/lib64 \
  --with-cxx \
  --with-gdal=/usr/local/bin/gdal-config \
  --without-odbc \
  --with-sqlite \
  --with-nls \
  --with-python \
  --with-wxwidgets=`which wx-config` \
  --with-fftw \
  --with-ffmpeg --with-ffmpeg-includes="/usr/include/libav* /usr/include/libpostproc /usr/include/libswscale" \
  --with-motif \
  --with-mysql --with-mysql-includes=/usr/include/mysql --with-mysql-libs=/usr/lib64 \
  --with-freetype --with-freetype-includes=/usr/include/freetype2 \
  --enable-largefile \
  2>&1 | tee config_log.txt

Get this file.

Please help us and report bugs.
Bug report form