REQUIREMENTS to compile GRASS GIS 7

A workstation running some flavor of UNIX like Solaris, IRIX, GNU/Linux, BSD, Mac OS X, Cygwin or MinGW (on Win32). Ideally, you should have at least 500 Mb. The source code package needs around 80 MB compressed. The resulting binaries may need between 20 MB and 180 MB depending on your platform. During a full compilation you may need temporarily up to 550MB including the source code.

To disable features please read the INSTALL file.

General requirements:

(most tools are standard tools on GNU/Linux, for other platforms you may have to install some of them.)

Optional requirements:

Note: also the respective xxx-dev or xxx-devel packages need to be installed.

Note:

SUN Solaris users may go here to download precompiled libraries etc.:
http://www.sunfreeware.com

SGI IRIX users may go here to download precompiled libraries etc.:
http://freeware.sgi.com

MacOSX users may go here to download precompiled libraries etc.:
http://fink.sourceforge.net


© GRASS Development Team 2001-2016

Please report bugs here:
http://grass.osgeo.org/development/bug-tracking/

Last changed: $Date: 2016-03-10 14:01:17 +0100 (Thu, 10 Mar 2016) $